this post was submitted on 17 Nov 2023
50 points (91.7% liked)
Programming
17326 readers
178 users here now
Welcome to the main community in programming.dev! Feel free to post anything relating to programming here!
Cross posting is strongly encouraged in the instance. If you feel your post or another person's post makes sense in another community cross post into it.
Hope you enjoy the instance!
Rules
Rules
- Follow the programming.dev instance rules
- Keep content related to programming in some way
- If you're posting long videos try to add in some form of tldr for those who don't want to watch videos
Wormhole
Follow the wormhole through a path of communities [email protected]
founded 1 year ago
MODERATORS
you are viewing a single comment's thread
view the rest of the comments
view the rest of the comments
I agree with part of the article, because I didn't read the rest. I truly dislike the use of single letter variable names:
f
,g
,h
andfoo
,bar
,baz
. My advice: use descriptive variable names.function twoIfs
,function complicatedIf
,var simpleAnd
, etc. Makes it so much easier to read examples instead of remembering "oh yeah,f
had two ifs in it,h
had the if/else,g
callsf
which callsh
which,...".Also see this often in other examples: "
A
for 'Truthy variable' " ๐ Wtf. Laziness is good when it makes things easier, not harder.The article is really not about naming conventions.
Should have still used them. It was harder to read this way.
I even thought that this (hardness) was intended to emphasize the way it's hard to spot problems in real codebase ๐
The blog author is literally using de-facto standard for placeholder names.
The var names used by the author are perfectly fine. They don't cause any issue, nor do they make things hard to read.
Doesn't matter, it's hard to read an article. If it were hard to read for another reason like bad grammar, I'd comment on that too ๐คท